Investigating: Base Sepolia Safe Head Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 01, 2026 - 13:58 UTC

Update

We are continuing to investigate this issue.
Posted May 01, 2026 - 13:57 UTC

Investigating

We are currently investigating a safe head stall on Base Sepolia. Requests dependent on the safe block tag may return stale data. Our team is actively working on a fix and will provide updates shortly.
Posted May 01, 2026 - 11:38 UTC
This incident affected: Base.