Ethereum Mainnet Node Fleet Upgrade – Ongoing

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 20:52 UTC

Update

APAC is now complete, USW is ongoing.
Posted Sep 16, 2025 - 19:22 UTC

Update

We are continuing to investigate this issue.
Posted Sep 16, 2025 - 17:44 UTC

Investigating

Status: Partial Mitigation / Upgrade in Progress
Regions Affected: EUC, APAC, USW

Details:
We recently observed elevated latencies and errors on ETH Mainnet due to an issue with a subset of Reth nodes. Mitigation steps have been applied: traffic is currently served from our Geth nodes in USE1, and Reth node upgrades are underway.

Current Impact:
Customers in the APAC region may experience slightly higher latencies while node upgrades are in progress.
EUC region has been fully upgraded, and traffic is now being served normally.

Next Steps:
Complete rolling upgrade of Reth nodes in APAC.
Re-enable all regions once upgrades are stable.

Disable full forwarding for trace methods after the upgrade is fully complete to restore normal operation.

Updates:
We will provide further updates as the APAC region upgrade completes and all regions return to normal latencies. Please reach out if you have any questions!
Posted Sep 16, 2025 - 17:40 UTC
This incident affected: Ethereum.