[Network-Wide] Ink Sepolia Finalized Tag Stalled

Incident Report for Alchemy

Resolved

The finalized tag on Ink Sepolia resumed advancing at 15:35 UTC. This incident has been resolved.
Posted May 15, 2026 - 17:12 UTC

Investigating

We are currently investigating a finalized head stall on Ink Sepolia. Requests dependent on the finalized block tag may return stale data. Our team is actively working with the Ink team and will provide updates shortly.
Posted May 15, 2026 - 15:15 UTC
This incident affected: Ink Chain.