Issue with Arbitrum archival support
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 10:15 PST
Update
The ledger growth has exacerbated performance issues for archive queries on nodes. These issues make for poor user experience when querying for archival data on Arbitrum, and as such these queries are blocked until the next binary release which should alleviate many of these issues.
Posted Sep 21, 2021 - 12:43 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 20, 2021 - 20:25 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 20, 2021 - 20:24 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 08, 2021 - 17:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 03, 2021 - 18:00 PDT
Investigating
Archive queries on Arbitrum are currently in beta support. We are working with the Arbitrum team to provide reliable archive queries. In the meantime, queries more than 64 blocks behind latest will not have reliable support on Arbitrum.
Posted Sep 03, 2021 - 18:00 PDT
This incident affected: Arbitrum Mainnet (JSON-RPC Request API) and Arbitrum Rinkeby (JSON-RPC Request API).