Degraded Performance on Roll Up Chains

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 17:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 15:23 UTC

Update

Networks Impacted:
unite testnet, boba mainnet, apechain curtis, openloot sepolia, k2 testnet, earnm mainnet, earnm testnet, zora mainnet, zora sepolia
Posted Oct 07, 2025 - 15:15 UTC

Investigating

We are currently investigating this issue.
Posted Oct 07, 2025 - 15:13 UTC