Polygon Amoy Degraded Performance - Load Test

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 18:26 UTC

Monitoring

Polygon is currently conducting a load test on the Amoy testnet. As a result, nodes are experiencing difficulty staying in sync, and customers may encounter degraded performance or delayed data on this network.

Customers using custom webhooks may also experience delays in event delivery. We are actively monitoring the situation.
Posted Apr 10, 2026 - 16:02 UTC
This incident affected: Polygon.