SSL Issues on RPC Endpoints

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 18:00 UTC

Investigating

We are currently observing SSL issues impacting customer traffic, with confirmed effects on Scroll and Shape chains and potential impact on additional chains. Our team is actively engaged with the Cloudflare team to identify the root cause and restore normal operations.
Posted Sep 29, 2025 - 13:07 UTC
This incident affected: Scroll and Shape.