[Network Wide] Unichain Sepolia Stalled on Block 21818269

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 31, 2025 - 02:00 UTC

Investigating

We observed that Unichain Sepolia is stuck on Block 21818269. This is a network wide incident: https://unichain-sepolia.blockscout.com/
Posted May 31, 2025 - 01:45 UTC
This incident affected: Unichain.