High Traffic on Base Network

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 18:33 UTC

Monitoring

No immediate issues. Across the network, there is heavy transaction volume on Base L2 is causing delays in batching data to Ethereum. Applications may notice lagging safe head as a result, and we're working to protect users from network wide issues.
Posted Oct 10, 2025 - 21:47 UTC
This incident affected: Base.