[Network Wide] Flow Testnet Block Production Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 18:32 UTC

Investigating

We're seeing the block production halted on Flow Test at the network level
Posted Jul 10, 2025 - 18:26 UTC
This incident affected: Flow.