Increased Latency and Errors for NFT APIs Across Multiple Networks

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 16:44 UTC

Update

We are continuing to investigate this issue.
Posted Jul 15, 2025 - 16:32 UTC

Investigating

We are currently investigating increased latency and errors for NFT API endpoints.
Posted Jul 15, 2025 - 16:24 UTC