[Network Wide] Citrea Mainnet Block Production Halted

Incident Report for Alchemy

Resolved

Block production on Citrea Mainnet has resumed and the network is operating normally. Transactions are being processed as expected.
Posted May 24, 2026 - 15:42 UTC

Investigating

We are aware that block production on Citrea Mainnet has stalled and are actively investigating the root cause. Transactions are not being processed at this time. Last block produced: 7767200 (https://explorer.mainnet.citrea.xyz/block/7767200)
Posted May 24, 2026 - 15:37 UTC
This incident affected: Citrea.