Impaired performance with Erigon nodes on Polygon Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 10:05 UTC

Monitoring

Our on-call engineering team has applied a hotfix and is monitoring the situation.
Posted Jul 01, 2025 - 09:24 UTC

Investigating

The Erigon portion of our Polygon Mainnet node fleet is currently stalled. This is a network-wide issue, and we're working closely with the Polygon team to fix it. As a result, you may experience 503 errors or request timeouts.

We will provide regular updates as we resolve this.
Posted Jul 01, 2025 - 09:19 UTC
This incident affected: Polygon.