Celo Mainnet Downtime (L1 to L2 Migration)

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 15:39 UTC

Monitoring

Celo Mainnet will be migrating to an L2 starting on Tuesday, March 25th 7:45PM PST (2:45AM UTC Wednesday, March 26th). Expect downtime for a few hours.
Posted Mar 24, 2025 - 23:39 UTC
This incident affected: Celo.