Solana Devnet Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 16:02 UTC

Identified

We have identified a network stall on Solana Devnet.

Please note that this stall is only affecting Devnet - not Mainnet nor Testnet.
Posted Jul 03, 2025 - 19:22 UTC
This incident affected: Solana.