Scroll Mainnet Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 15:25 UTC

Investigating

We are currently investigating. https://scrollscan.com/ is also stuck.
Posted Jan 14, 2026 - 15:03 UTC
This incident affected: Scroll.