Fraxtal Hoodi Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 15:34 UTC

Investigating

We are currently experiencing degraded performance on Fraxtal Hoodi due to a network wide issue. You can track the status of this incident here: https://hoodi.fraxscan.com/
Posted Apr 23, 2026 - 15:01 UTC