Unichain Sepolia Not Updating to the Latest Block

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted 26 days ago. Mar 11, 2025 - 16:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Mar 10, 2025 - 16:35 UTC

Investigating

Nodes on the current network have fallen behind the latest block number, and may return outdated block information. We're looking into the issue now and will provide an update ASAP!
Posted 27 days ago. Mar 10, 2025 - 15:36 UTC
This incident affected: Unichain.