BNB Chain degraded performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 18:24 UTC

Investigating

We are currently investigating occasional errors on BNB Chain. Customers may experience degraded performance.
Posted Oct 07, 2025 - 14:42 UTC
This incident affected: BNB Smart Chain.