Ethereum Sepolia RPC Degradation Hardfork

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 17:31 UTC

Investigating

We are investigating an issue affecting Sepolia RPC requests, where pending state errors (-32000) and increased latency are impacting transaction submissions and batch posting across Eth Sepolia and L2s.

The issue is linked to the recent Pectra upgrade and required Geth node upgrades. Our team has deployed fixes and is actively monitoring performance. We will provide further updates as the situation stabilizes!
Posted Mar 05, 2025 - 14:48 UTC
This incident affected: Ethereum.