[Network Wide] Celo Alfajores Block Stalled

Incident Report for Alchemy

Resolved

Block production resumed on Celo Alfajores
Posted Oct 02, 2025 - 14:09 UTC

Investigating

Celo Alfajores block production is stalled on block 58410172 mined (Oct-02-2025 12:38:12 AM +UTC): https://alfajores.celoscan.io/block/58410172

This is a network wide incident and we'll keep this status page up to date
Posted Oct 02, 2025 - 00:55 UTC
This incident affected: Celo.