Opt Sepolia Blocks Stalled
Incident Report for Alchemy
Resolved
Optimism team has resolved this network wide issue and blocks are being mined again on Opt Sepolia! 🎉
Posted Jul 23, 2024 - 19:48 UTC
Investigating
Optimism Sepolia Network has stopped to produce blocks. Latest block mined was 14979169 at this timestamp Jul-23-2024 06:54:38 PM UTC.

This is a network wide issue and we will update this incident based on the latest news from the Optimism team!
Posted Jul 23, 2024 - 19:21 UTC
This incident affected: Optimism.