Elevated latency with Enhanced APIs on multiple chains.

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 13:39 UTC

Monitoring

Our team has deployed a fix, and system latency has returned to normal levels. We have been monitoring stability for the past 30 minutes with no further anomalies observed.
Posted Oct 24, 2025 - 13:10 UTC

Investigating

We are currently investigating elevated latency impacting our Enhanced APIs. This may cause increased response times and potential timeouts for some requests.

Our engineering team is actively working to identify the root cause and restore normal performance as soon as possible.
Posted Oct 24, 2025 - 10:34 UTC
This incident affected: Ethereum, ApeChain, Gnosis, Polygon, and Scroll.