Base Mainnet Network Wide Stall

Incident Report for Alchemy

Resolved

This incident has been resolved and we've restarted our nodes.
Posted Jun 25, 2026 - 18:24 UTC

Update

The Base team has confirmed network-wide issues on their status page. Please follow this page for the latest updates: https://base-l2.statuspage.io/incidents/5c4gm1wzbjs4
Posted Jun 25, 2026 - 16:07 UTC

Investigating

We are currently investigating a network-wide stall on Base Mainnet at block 0x2d9784e. We’re working with the Base team to get more details on the issue.
Posted Jun 25, 2026 - 15:58 UTC
This incident affected: Base.