Service Degradation on Unichain Mainnet & Testnet

Incident Report for Alchemy

Resolved

Polygon team implemented a fix and the situation is back to normal! See more details in their status page here: https://status.unichain.org/cmgb56k8201ghhrwxqujgmyji
Posted Oct 04, 2025 - 00:13 UTC

Investigating

We’re aware of an ongoing issue impacting Unichain Mainnet & Testnet. This is currently causing a stall in safe head progression and no new state root updates.

Transactions may still be submitted but confirmations and finalized state updates may be delayed until mitigation is complete.

The Unichain team has shared a tentative mitigation time of ~2 hours. We’re closely monitoring the situation and will provide updates as soon as more information becomes available!
Posted Oct 03, 2025 - 17:52 UTC
This incident affected: Unichain.