Degraded performance on Solana mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 16:25 UTC

Identified

The issue has been identified and we've rolled out a fix.
Posted Jul 15, 2026 - 16:12 UTC

Investigating

We are currently investigating an issue resulting in increased errors and latency on Solana mainnet.
Posted Jul 15, 2026 - 16:00 UTC
This incident affected: Solana, US West, and AP SE.