Polygon Amoy Elevated 503s

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 10:02 UTC

Investigating

We are currently experiencing elevated 503 errors on Polygon Amoy and we're actively working to restore nodes!
Posted Nov 19, 2025 - 19:45 UTC
This incident affected: Polygon.