Polygon zkEVM Mainnet — Network-level instability until Polygon confirms and completes rehashing event (scheduled for Sept. 18th)
Incident Report for Alchemy
Resolved
This was resolved on Sept 19th.
Posted Sep 21, 2023 - 17:27 UTC
Update
From Polygon:

Rehashing + Bridge resync operations have begun.
https://t.me/polygonzkevm_technical_updates
Posted Sep 18, 2023 - 08:35 UTC
Identified
A regression in the latest zkEVM node client version (v0.2.5) released by the Polygon team is causing inconsistent block hashes to be returned for identical blocks, and may result in occasional downstream effects such as 5XX errors.

The Polygon zkEVM team will be conducting a network-wide block rehashing event (including a resync of the L2 bridge) scheduled for Monday September 18th to address these errors.

Date: Mon, Sept 18
Time: 10:30 AM CEST / 08:30 AM UTC
Duration: 6 hours

The network will resync from genesis, the state of the transactions stay the same but the L2 block hashes will change.

Rehashing will be followed by an L2 resync of the bridge.

Details on that event can be found here:
https://twitter.com/0xPolygon/status/1703033665012510870
Posted Sep 03, 2023 - 21:00 UTC