Base Sepolia Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 12:58 UTC

Investigating

We are investigating a stall on Base Sepolia. This appears to be a chain-wide issue. We will provide updates as we learn more.
Posted Feb 23, 2026 - 12:17 UTC
This incident affected: Base.