[Network Wide] CrossFi Testnet Block Stalled

Incident Report for Alchemy

Resolved

Block production has resolved on CrossFi testnet
Posted Jul 13, 2025 - 16:41 UTC

Investigating

Block production stalled on CrossFi Mainnet. This is a network wide incident and we're working closely with CrossFi team on this
Posted Jul 11, 2025 - 13:53 UTC
This incident affected: CrossFi.