Hyperliquid Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 06:22 UTC

Update

We managed to fix underlying issue with eth_getLogs, Websockets remain to be affected.
Posted Jun 12, 2026 - 05:30 UTC

Update

HTTP requests are progressing again. Customers may still experience issues with eth_getLogs and WebSockets. We are actively investigating and will provide further updates shortly.
Posted Jun 12, 2026 - 05:25 UTC

Investigating

We are currently investigating Hyperliquid Mainnet stall at block 37597796.
Posted Jun 12, 2026 - 05:05 UTC
This incident affected: HyperEVM.