Multiple Networks - Increased Latencies (Token/Portfolio API)

Incident Report for Alchemy

Resolved

This incident has been resolved. Between approximately 21:58 UTC and 22:12 UTC, some API requests across multiple networks experienced elevated latency, primarily affecting Token API and Portfolio API balance lookups.

All services are currently operating normally. We will continue to investigate the underlying cause to prevent recurrence!
Posted Aug 26, 2026 - 22:12 UTC

Investigating

We are currently investigating reports of elevated latency affecting Token API balance lookups and related endpoints across multiple networks. We will provide an update as more information becomes available!
Posted Aug 26, 2026 - 21:58 UTC
This incident affected: Robinhood.