Elevated 503 Errors Across Multiple Networks for NFT, Transfers, and Token Balances APIs

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 19:32 UTC

Monitoring

The observed elevated latencies started going down at 17:40 UTC, and we’re continuing to monitor the situation.
Posted Jun 23, 2025 - 17:40 UTC

Investigating

We’ve observed elevated 503 errors across multiple networks for our NFT, Transfers, and Token Balances APIs. We are actively investigating the issue.
Posted Jun 23, 2025 - 16:20 UTC