[Network-Wide] Abstract Mainnet Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 17:39 UTC

Investigating

We are investigating a network-wide stall on Abstract Mainnet at block #71,688,310 with no new blocks being produced.
Posted Jun 24, 2026 - 17:26 UTC
This incident affected: Abstract.