Increased Errors and Latency Across Multiple Networks for Token Balances and Wallet Services APIs

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 01:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2025 - 23:43 UTC

Investigating

We’ve observed elevated errors and latency across multiple networks for our Token Balances and Wallet Services APIs. We are actively investigating the issue.
Posted Jun 23, 2025 - 23:20 UTC