Arbitrum Sepolia Block Stalled at 97627861

Incident Report for Alchemy

Resolved

Blocks are now being mined again!
Posted Nov 15, 2024 - 17:04 UTC

Identified

This is a network wide incident - Arbitrum Sepolia mined blocked stopped at 97627861: https://sepolia.arbiscan.io/block/97627871
Posted Nov 15, 2024 - 16:38 UTC
This incident affected: Arbitrum.