Elevated Latency on Hyperliquid Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:34 UTC

Monitoring

We have pushed a fix and are seeing improvement in the latency metrics.
Posted Nov 18, 2025 - 05:33 UTC

Investigating

We are experiencing increased latency on Hyperliquid Mainnet Our engineering team are actively investigating.
Posted Nov 18, 2025 - 05:13 UTC
This incident affected: HyperEVM.