Degraded Service on Polygon Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 08:56 UTC

Update

The hotfix provided by the Polygon core team has been found to introduce performance degradation in both Bor and Erigon execution layer clients. As a result, node synchronization is adversely affected.

We are actively coordinating with the Polygon team to assess remediation paths and determine the safest resolution strategy. Further updates will be shared as we progress.
Posted Jul 30, 2025 - 12:17 UTC

Identified

We are currently observing a protocol-wide halt on the Polygon mainnet at block height 74,592,238. This disruption is impacting transaction finalization, block propagation, and all dependent network operations.

Our engineering team is actively implementing a node upgrade to remediate the issue.
Posted Jul 30, 2025 - 11:42 UTC
This incident affected: Polygon.