[Network-wide] Flow Testnet block production stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 10:30 UTC

Identified

Flow Testnet underwent a network-wide upgrade (spork) and following the upgrade, some infrastructure components encountered issues.

We have restored and resynced our nodes, our infrastructure is now healthy and aligned with the latest produced block!

At this time, block production remains stalled at the network level. There is no impact to Flow Mainnet.

We are continuing to monitor the situation closely and will keep this status page updated!
Posted Feb 12, 2026 - 20:07 UTC

Investigating

Flow Testnet is currently experiencing issues with block production. Our team is monitoring the situation - please refer to the official Flow status page for further updates: https://status.flow.com/incidents/wmbfxpwhgz64
Posted Feb 12, 2026 - 03:45 UTC