ZKSync Mainnet- Block Finalization Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 26, 2026 - 12:57 UTC

Investigating

We are currently investigating an issue affecting ZKSync Mainnet where block finalization has stalled. This appears to be an upstream issue with the ZKSync network. We are actively monitoring the situation and have engaged the ZKSync team. We will provide updates as the investigation progresses.
Posted May 25, 2026 - 08:30 UTC
This incident affected: ZKsync.