Increase block lag across multiple networks

Incident Report for Alchemy

Resolved

Elevated memory usage led to block lag across a handful of network in our US East region. This occurred in a part of our system that was built to maintain consistent, synchronized block tips among all nodes. Our engineering team is actively monitoring the these mechanisms to ensure that our system remains stable.
Posted Jan 20, 2026 - 15:58 UTC

Identified

We're experiencing block lag across multiple networks.

Team is investigating.
Posted Jan 20, 2026 - 12:45 UTC