Elevated Latency and Timeouts on EAPI Services

Incident Report for Alchemy

Resolved

This incident has. been resolved
Posted Jul 30, 2025 - 17:06 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Jul 30, 2025 - 14:33 UTC

Investigating

We're currently experiencing increased latency and timeout errors across our EAPI services including endpoints such as our Portfolio API. Our team is actively investigating the root cause and working to restore normal performance as quickly as possible.
Posted Jul 30, 2025 - 14:21 UTC