Elevated API Errors and Latency

Incident Report for Alchemy

Resolved

All networks latencies are back to baseline.
Posted Aug 31, 2026 - 15:34 UTC

Update

Arbitrum, BSC and Robinhood continue to exhibit slightly higher latencies than baseline.

All other networks are back to baseline.
Posted Aug 31, 2026 - 15:18 UTC

Update

All networks are seeing recovery. We're continuing to monitor.

You might still see elevated latencies on Arbitrum, BSC and Robinhood. We expect them to come back to baseline shortly.
Posted Aug 31, 2026 - 15:03 UTC

Update

Arbitrum Mainnet is seeing recovery. We're continuing to monitor.
Posted Aug 31, 2026 - 15:00 UTC

Update

Robinhood Mainnet is seeing recovery. We're continuing to monitor.
Posted Aug 31, 2026 - 15:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 31, 2026 - 14:57 UTC

Investigating

We’re investigating elevated error rates and latency affecting some API requests across multiple regions. Our team is actively working to restore normal performance.
Posted Aug 31, 2026 - 14:39 UTC