Robinhood Mainnet - Elevated latencies and Increased Request Failures

Incident Report for Alchemy

Resolved

Service is now fully recovered, nodes are caught up with the chain and error rates are back to baseline! Instability upstream on Robinhood chain was concluded as a root cause.
Posted Sep 04, 2026 - 13:32 UTC

Update

We are continuing to investigate this issue.

Team noticed that this is driven by an upstream issue on Robinhood Mainnet - a sharp increase in on-chain activity and block size, combined with brief instability on Robinhood's sequencer feed. This caused some of our nodes to briefly fall behind the chain tip and, during the worst of it, a short window of failed requests.
Posted Sep 04, 2026 - 12:56 UTC

Investigating

We are currently investigating this issue.
Posted Sep 04, 2026 - 12:50 UTC
This incident affected: Robinhood.