Avax Testnet Issues

Incident Report for Alchemy

Resolved

The Avalanche team has released a new version (AvalancheGo v1.13.0-fuji) to address the instability issues affecting Fuji nodes: https://status.avax.network/incidents/n4dnd7sb1n6h

We’ve now upgraded our nodes accordingly and everything should be running smoothly again!
Posted Mar 07, 2025 - 02:35 UTC

Investigating

Avalanche Testnet is undergoing a network wide issue
Updates from Avalanche team: https://status.avax.network/incidents/n4dnd7sb1n6h
Posted Mar 05, 2025 - 23:28 UTC
This incident affected: Avalanche C Chain.