Arbitrum Sepolia Network Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 17:44 UTC

Update

Block are being produce again: https://sepolia.arbiscan.io/

See the Arbitrum status page for full details: https://status.arbitrum.io/cm7xmg3ga002sz8snml0zso5o
Posted Mar 06, 2025 - 17:44 UTC

Investigating

We are currently experiencing a network-wide stall on Arbitrum Sepolia. This issue is affecting transaction processing and block production. Latest block produced on chain: 129933678 - see block explorer: https://sepolia.arbiscan.io/

We will provide further updates as soon as we have more information! Thank you for your patience!
Posted Mar 06, 2025 - 17:17 UTC
This incident affected: Arbitrum.