Degraded Performance on Polygon Mainnet

Incident Report for Alchemy

Identified

The Polygon team has helped us identify the underlying issue and has assisted in providing a hotfix. Our engineerings are currently validating the fix.
Posted Nov 20, 2025 - 15:29 UTC

Investigating

The Erigon segment of our Polygon Mainnet node fleet is experiencing synchronization issues. This may result in elevated 32xxx errors for requests that depend on historical state. Our team is actively applying corrective measures and coordinating directly with the Polygon team to accelerate full remediation.
Posted Nov 19, 2025 - 13:11 UTC
This incident affects: Polygon.