[Network Wide] Zetachain Mainnet Block Production Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 18:30 UTC

Investigating

We're observing a network wide chain stalled on Zetachain mainnet - stopped at block: 18349554

See Zetachain block explorer here: https://zetascan.com/block/18349554
Posted Aug 25, 2026 - 13:31 UTC
This incident affected: Zetachain.