EU Central Region - Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 08:14 UTC

Investigating

We are investigating consistency issues affecting our EU Central region beginning around 06:58 UTC. Some customers may experience degraded or inconsistent API responses across multiple chains. Mitigation is in progress.
Posted Jun 02, 2026 - 06:58 UTC
This incident affected: EU Central.