Investigating - Mythos Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 20:13 UTC

Monitoring

We have applied a fix, and the degraded nodes are syncing. Our on-call team is monitoring the situation and will continue to share updates.
Posted Jun 30, 2026 - 17:14 UTC

Investigating

We are investigating a chain halt on Mythos Mainnet. The canonical head has stalled, and several nodes have been identified as degraded. Our team is in a war room and working on a resolution.
Posted Jun 30, 2026 - 16:52 UTC
This incident affected: Mythos.